db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mamta Satoor <msat...@gmail.com>
Subject Re: Compatibility test runs?
Date Mon, 13 Sep 2010 17:54:29 GMT
I ran following to get info on how to run the compatibility test
ant -buildfile testScript.xml -projecthelp

It seems to currently only test 10.0 through 10.2 releases of network
server products. Is it just out of date and we need to change the
script to allow users to specify higher releases of products? Does
Ole's nightly tests only test network server/client combinations for
10.0 through 10.2?

thanks,
Mamta

On Thu, Sep 9, 2010 at 3:18 PM, Myrna van Lunteren
<m.v.lunteren@gmail.com> wrote:
> On Thu, Sep 9, 2010 at 2:02 PM, Mamta Satoor <msatoor@gmail.com> wrote:
>> Hi,
>>
>> I am working on a jira DERBY-4786 which requires testing of different
>> versions of client and server. It appears that there is something
>> called CompatibilitySuite.java. Is that what I would be running to
>> test the compatibility between different versions? How do I run that
>> test? Will I be able to test different revisions of the same major
>> release, for instance, say client at revision 10.3.3.1 against server
>> at 10.3.1.4? Then, I need to add a test of my own to the compatibility
>> test suite to try shutdown between different versions of clients and
>> servers.
>>
>> thanks,
>> Mamta
>>
>
> Hi Mamta,
>
> There's a CompatibilitySuite.java in
> java/testing/org/apache/derbyTesting/functionTests/tests/junitTests/compatibility.
> It has a README.html.
>
> Hope this helps.
> Myrna
>

Mime
View raw message