db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "joseph vychtrle (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DERBY-4797) Derby Eclipse plugin doesn't get installed after dropping
Date Fri, 10 Sep 2010 12:50:33 GMT

     [ https://issues.apache.org/jira/browse/DERBY-4797?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

joseph vychtrle updated DERBY-4797:
-----------------------------------

    Description: 
Plugins dropped into eclipse dropin directory didn't get installed after restart.

lisak@sonofagun:/opt/eclipse-helios/dropins$ tree -L 2
.
|-- org.apache.derby.core_10.6.1
|   |-- LICENSE
|   |-- NOTICE
|   |-- derby.jar
|   |-- derbyclient.jar
|   |-- derbynet.jar
|   |-- derbytools.jar
|   `-- plugin.xml
|-- org.apache.derby.plugin.doc_1.1.2
|   |-- LICENSE
|   |-- NOTICE
|   |-- plugin.xml
|   |-- toc.xml
|   `-- topics
`-- org.apache.derby.ui_1.1.2
    |-- LICENSE
    |-- NOTICE
    |-- icons
    |-- plugin.xml
    `-- ui.jar

IAction.run() error org.eclipse.core.runtime.CoreException: The archive: /opt/eclipse-helios/plugins/org.apache.derby.core_10.3.2/derby.jar
which is referenced by the classpath, does not exist.


PLUGINS DIRECTORY AFTER DROPPING PLUGIN IN


lisak@sonofagun:/opt/eclipse-helios$ ff *derby*
./plugins/org.eclipse.datatools.sqltools.db.derby.ui_1.0.0.v200906020900.jar
./plugins/org.eclipse.datatools.connectivity.apache.derby.dbdefinition_1.0.2.v200906161815.jar
./plugins/org.eclipse.datatools.connectivity.apache.derby_1.0.100.v200906020900.jar
./plugins/org.eclipse.datatools.connectivity.apache.derby.ui_1.0.2.v201005130645.jar
./plugins/org.apache.derby_10.5.1.1_201005192117.jar
./plugins/org.eclipse.datatools.sqltools.db.derby_1.0.0.v200906020900.jar
./plugins/org.eclipse.datatools.modelbase.derby_1.0.0.v201002161452.jar
./configuration/org.eclipse.osgi/manifests/org.apache.derby.core_10.6.1.0.MF
./configuration/org.eclipse.osgi/manifests/org.apache.derby.plugin.doc_1.1.2.MF
./configuration/org.eclipse.osgi/manifests/org.apache.derby.ui_1.1.2.MF
./dropins/org.apache.derby.core_10.6.1/derbyclient.jar
./dropins/org.apache.derby.core_10.6.1/derbynet.jar
./dropins/org.apache.derby.core_10.6.1/derbytools.jar
./dropins/org.apache.derby.core_10.6.1/derby.jar
./dropins/org.apache.derby.plugin.doc_1.1.2/topics/derby_app.html

PLUGINS DIRECTORY WITHOUT DROPPING PLUGIN IN

lisak@sonofagun:/opt/eclipse-helios$ ff *derby*
./plugins/org.eclipse.datatools.sqltools.db.derby.ui_1.0.0.v200906020900.jar
./plugins/org.eclipse.datatools.connectivity.apache.derby.dbdefinition_1.0.2.v200906161815.jar
./plugins/org.eclipse.datatools.connectivity.apache.derby_1.0.100.v200906020900.jar
./plugins/org.eclipse.datatools.connectivity.apache.derby.ui_1.0.2.v201005130645.jar
./plugins/org.apache.derby_10.5.1.1_201005192117.jar
./plugins/org.eclipse.datatools.sqltools.db.derby_1.0.0.v200906020900.jar
./plugins/org.eclipse.datatools.modelbase.derby_1.0.0.v201002161452.jar
./configuration/org.eclipse.osgi/manifests/org.apache.derby.core_10.6.1.0.MF
./configuration/org.eclipse.osgi/manifests/org.apache.derby.plugin.doc_1.1.2.MF
./configuration/org.eclipse.osgi/manifests/org.apache.derby.ui_1.1.2.MF



  was:
Plugins dropped into eclipse dropin directory didn't get installed after restart.

lisak@sonofagun:/opt/eclipse-helios/dropins$ tree -L 2
.
|-- org.apache.derby.core_10.6.1
|   |-- LICENSE
|   |-- NOTICE
|   |-- derby.jar
|   |-- derbyclient.jar
|   |-- derbynet.jar
|   |-- derbytools.jar
|   `-- plugin.xml
|-- org.apache.derby.plugin.doc_1.1.2
|   |-- LICENSE
|   |-- NOTICE
|   |-- plugin.xml
|   |-- toc.xml
|   `-- topics
`-- org.apache.derby.ui_1.1.2
    |-- LICENSE
    |-- NOTICE
    |-- icons
    |-- plugin.xml
    `-- ui.jar

IAction.run() error org.eclipse.core.runtime.CoreException: The archive: /opt/eclipse-helios/plugins/org.apache.derby.core_10.3.2/derby.jar
which is referenced by the classpath, does not exist.


I just added what is in plugin directory as to derby plugin

> Derby Eclipse plugin doesn't get installed after dropping
> ---------------------------------------------------------
>
>                 Key: DERBY-4797
>                 URL: https://issues.apache.org/jira/browse/DERBY-4797
>             Project: Derby
>          Issue Type: Bug
>          Components: Eclipse Plug-in
>    Affects Versions: 10.6.1.0
>         Environment: Linux x64, eclipse helios
>            Reporter: joseph vychtrle
>
> Plugins dropped into eclipse dropin directory didn't get installed after restart.
> lisak@sonofagun:/opt/eclipse-helios/dropins$ tree -L 2
> .
> |-- org.apache.derby.core_10.6.1
> |   |-- LICENSE
> |   |-- NOTICE
> |   |-- derby.jar
> |   |-- derbyclient.jar
> |   |-- derbynet.jar
> |   |-- derbytools.jar
> |   `-- plugin.xml
> |-- org.apache.derby.plugin.doc_1.1.2
> |   |-- LICENSE
> |   |-- NOTICE
> |   |-- plugin.xml
> |   |-- toc.xml
> |   `-- topics
> `-- org.apache.derby.ui_1.1.2
>     |-- LICENSE
>     |-- NOTICE
>     |-- icons
>     |-- plugin.xml
>     `-- ui.jar
> IAction.run() error org.eclipse.core.runtime.CoreException: The archive: /opt/eclipse-helios/plugins/org.apache.derby.core_10.3.2/derby.jar
which is referenced by the classpath, does not exist.
> PLUGINS DIRECTORY AFTER DROPPING PLUGIN IN
> lisak@sonofagun:/opt/eclipse-helios$ ff *derby*
> ./plugins/org.eclipse.datatools.sqltools.db.derby.ui_1.0.0.v200906020900.jar
> ./plugins/org.eclipse.datatools.connectivity.apache.derby.dbdefinition_1.0.2.v200906161815.jar
> ./plugins/org.eclipse.datatools.connectivity.apache.derby_1.0.100.v200906020900.jar
> ./plugins/org.eclipse.datatools.connectivity.apache.derby.ui_1.0.2.v201005130645.jar
> ./plugins/org.apache.derby_10.5.1.1_201005192117.jar
> ./plugins/org.eclipse.datatools.sqltools.db.derby_1.0.0.v200906020900.jar
> ./plugins/org.eclipse.datatools.modelbase.derby_1.0.0.v201002161452.jar
> ./configuration/org.eclipse.osgi/manifests/org.apache.derby.core_10.6.1.0.MF
> ./configuration/org.eclipse.osgi/manifests/org.apache.derby.plugin.doc_1.1.2.MF
> ./configuration/org.eclipse.osgi/manifests/org.apache.derby.ui_1.1.2.MF
> ./dropins/org.apache.derby.core_10.6.1/derbyclient.jar
> ./dropins/org.apache.derby.core_10.6.1/derbynet.jar
> ./dropins/org.apache.derby.core_10.6.1/derbytools.jar
> ./dropins/org.apache.derby.core_10.6.1/derby.jar
> ./dropins/org.apache.derby.plugin.doc_1.1.2/topics/derby_app.html
> PLUGINS DIRECTORY WITHOUT DROPPING PLUGIN IN
> lisak@sonofagun:/opt/eclipse-helios$ ff *derby*
> ./plugins/org.eclipse.datatools.sqltools.db.derby.ui_1.0.0.v200906020900.jar
> ./plugins/org.eclipse.datatools.connectivity.apache.derby.dbdefinition_1.0.2.v200906161815.jar
> ./plugins/org.eclipse.datatools.connectivity.apache.derby_1.0.100.v200906020900.jar
> ./plugins/org.eclipse.datatools.connectivity.apache.derby.ui_1.0.2.v201005130645.jar
> ./plugins/org.apache.derby_10.5.1.1_201005192117.jar
> ./plugins/org.eclipse.datatools.sqltools.db.derby_1.0.0.v200906020900.jar
> ./plugins/org.eclipse.datatools.modelbase.derby_1.0.0.v201002161452.jar
> ./configuration/org.eclipse.osgi/manifests/org.apache.derby.core_10.6.1.0.MF
> ./configuration/org.eclipse.osgi/manifests/org.apache.derby.plugin.doc_1.1.2.MF
> ./configuration/org.eclipse.osgi/manifests/org.apache.derby.ui_1.1.2.MF

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message