db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knut Anders Hatlen <Knut.Hat...@Sun.COM>
Subject Re: Getting the following error when using 10.6.1 derby jar
Date Mon, 05 Jul 2010 13:02:26 GMT
Jayaram Subramanian <rsjay1976@gmail.com> writes:

> Hi,
> I created a database using ij from eclipse and then tried to connect
> to db using 10.6.1 derby.jar.. I get the following exception.. Am i
> doing something wrong..??
>
> With Regards
> Jayaram
>
> Caused by: java.sql.SQLException: Database at
> C:\java\Derby\source\trunk\SpringDbTest is at version 10.7 beta. Beta
> databases cannot be upgraded,

Hi Jayaram,

It looks like you created the database with trunk, and then you cannot
open it with 10.6, since we don't support downgrading the database. It
should work if you try to open the database with the same version that
you used to create it.

-- 
Knut Anders

Mime
View raw message