db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nirmal Fernando <nirmal070...@gmail.com>
Subject Re: Problem of using Xalan in PlanExporter tool
Date Tue, 20 Jul 2010 03:18:42 GMT
Hi Kim,

Thanks for the reply. Bryan prefers to use an old xalan version, and
I'm checking the possibility of using it.


On Tue, Jul 20, 2010 at 2:34 AM, Kim Haase <camilla.haase@oracle.com> wrote:
> I think it would make sense to do that, but check with Bryan to make sure.
>
> Kim
>
> On 07/19/10 01:47 PM, Nirmal Fernando wrote:
>>
>> Hi Kim,
>>
>> Thanks for finding the documentation.
>>
>> So, will it be ok to ask an user to follow that
>> procedure, if he/she is using jdk1.4/1.5 before
>> starting the new tool?
>>
>> Thanks.
>>
>> On Mon, Jul 19, 2010 at 11:09 PM, Kim Haase <camilla.haase@oracle.com>
>> wrote:
>>>
>>> Hi, Nirmal,
>>>
>>> The recommended mechanism is documented in the Derby Developer's Guide:
>>>
>>>
>>> http://db.apache.org/derby/docs/dev/devguide/devguide-single.html#cdevstandardsxml
>>>
>>> Hope this a) makes sense and b) works.
>>>
>>> Kim
>>>
>>> On 07/19/10 10:10 AM, Nirmal Fernando wrote:
>>>>
>>>> Hi All,
>>>>
>>>> I used xalan.jar's classes to convert a XML to HTML
>>>> using an XSL style sheet. I was successfully compile
>>>> and build the code.
>>>>
>>>> But yesterday Bryan mentioned that
>>>> the code is failed to compile successfully, in his environment.
>>>>
>>>> Today I found that problem is with JDK version and xalan.
>>>> JDK/JRE by default contain a xalan-java classes in it and according
>>>> to xalan site (http://xml.apache.org/xalan-j/faq.html#faq-N100EF)
>>>> JDK/JRE 1.4, and JDK/JRE 5.0 is packaged with an old
>>>> version of Xalan-Java and the JDK/JRE will attempt to use this version
>>>> instead of any on the classpath.
>>>>
>>>> In my case I didn't get any errors is because, I'm using java 1.6.0,
>>>> but Bryan (Derby as well) using java 1.4.2.
>>>> For this problem there's a work around given at Xalan site.
>>>> It is,
>>>>
>>>> "To use a newer version of Xalan-Java and override the one packaged
>>>> with the JDK:
>>>>    use the Endorsed Standards Override
>>>> Mechanism(http://java.sun.com/j2se/1.4.2/docs/guide/standards/).
>>>> Place the xalan.jar, serializer.jar, xercesImpl.jar and xml-apis.jar in
>>>> the
>>>> <java-home>\lib\endorsed directory, where <java-home> is where
the
>>>> runtime software is installed."
>>>>
>>>> Another option would be to avoid using new version of xalan,
>>>> and try to use old version that is packaged with JDK/JRE 1.4.
>>>> I'm now looking the possibilty of using old version of xalan.
>>>>
>>>> If you have any other idea please suggest me.
>>>>
>>>> Thank you very much!
>>>>
>>>> --
>>>> Best Regards,
>>>> Nirmal
>>>>
>>>> C.S.Nirmal J. Fernando
>>>> Department of Computer Science & Engineering,
>>>> Faculty of Engineering,
>>>> University of Moratuwa,
>>>> Sri Lanka.
>>>>
>>
>>
>>
>



-- 
Best Regards,
Nirmal

C.S.Nirmal J. Fernando
Department of Computer Science & Engineering,
Faculty of Engineering,
University of Moratuwa,
Sri Lanka.

Mime
View raw message