db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nirmal Fernando <nirmal070...@gmail.com>
Subject Re: PlanExporter library requirements (DERBY-4587) (long message)
Date Sat, 24 Jul 2010 12:37:30 GMT
Hi All,

I like to add my thoughts as well. I understand now, that adding
external libraries such as Xalan or JQuery will affect the Derby's low
footprint, both in code size and in runtime resource requirements as
Bryan clearly explained. So, I think it's better for our users to
avoid those external libraries as possible as we can.

I investigated of using an old Xalan version that is compatible with
JDK 1.4, and I'm happy to inform you that I've successfully managed to
do that, and my latest patch resolved it.

Secondly about using JQuery, I think it's enough to give our users few
XSL style sheets which are in different styles, so they can choose
either one of them as their preferences or an external style sheet
developed by them. For these style sheets I'm planning to use CSS and
JS, by writing my own code.

I would like to know will it be good enough?

Highly appreciate all of your ideas on this tool.

Thanks.

Best Regards,
Nirmal

C.S.Nirmal J. Fernando
Department of Computer Science & Engineering,
Faculty of Engineering,
University of Moratuwa,
Sri Lanka.

Mime
View raw message