db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "EDAH-TALLY (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DERBY-4745) Custom Authentication Provider : ClassNotFoundException
Date Fri, 16 Jul 2010 14:33:50 GMT

     [ https://issues.apache.org/jira/browse/DERBY-4745?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

EDAH-TALLY updated DERBY-4745:
------------------------------

    Description: 
Hello,

I'm trying to implement the custom authentication provider facility of Derby and am constantly
hitting against a ClassNotFoundException.

I created a DB on a Derby server running in ssl mode basic with no security manager. The DB
is created with the following properties : 

        CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY('derby.connection.requireAuthentication',
'true')
        CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY('derby.database.defaultConnectionMode',
'noAccess')
        CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY('derby.database.propertiesOnly', 'true')
        CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY('derby.authentication.provider', 'lab.DerbyAP')

derby.authentication.provider points to the custom class lab.DerbyAP, which is in a jar file
on the server and in the classpath of the script starting the server (see attachement).

When the DB is created, an authorized user can connect normally.
If the server is shutdown and started again, no one can connect again. The database can't
be booted on account of the custom class lab.DerbyAP not being found, though it is present
and in the classpath.

I attach also derby.log and sysinfo output or details.

It seems that the server can't find at all a class in the classpath, or the classpath 'inside'
the server does not reference the class.

I tried also using the derby.database.classpath property after installing the jar file containing
the custom class using sqlj.install_jar, but to no avail. The ClassNotFoundException still
gets fired.

I can't see what I'm missing, it smells like a single simple point but after three days researching
the problem... it's getting long !

Please advse.

Thank you.

  was:
Hello,

I'm trying to implement the custom authentication provider facility of Derby and am constantly
hitting against a ClassNotFoundException.

I created a DB on a Derby server running in ssl mode basic with no security manager. The DB
is created with the following properties : 

        CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY('derby.connection.requireAuthentication',
'true')
        CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY('derby.database.defaultConnectionMode',
'noAccess')
        CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY('derby.database.propertiesOnly', 'true')
        CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY('derby.authentication.provider', 'lab.DerbyAP')

derby.authentication.provider points to the custom class lab.DerbyAP, which is in jar file
on the server and in the classpath of the script starting the server (see attachement).

When the DB is created, an authorized user can connect normally.
If the server is shutdown and started again, no one can connect again. The database can't
be booted on account of the custom class lab.DerbyAP not being found, though it i present
and in the classpath.

I attach also derby.log and sysinfo output or details.

It seems that the can't find at all a class in the classpath, or the classpath 'inside' the
server does not reference the class.

I tried also using the derby.database.classpath property after installing the jar file containing
the custom class using sqlj.install_jar, but to no avail. The ClassNotFoundException still
gets fired.

I can't see what I'm missing, it smells like a single simple point but after three days researching
the problem... it's getting long !

Please advse.

Thank you.


> Custom Authentication Provider : ClassNotFoundException
> -------------------------------------------------------
>
>                 Key: DERBY-4745
>                 URL: https://issues.apache.org/jira/browse/DERBY-4745
>             Project: Derby
>          Issue Type: Bug
>          Components: JDBC
>    Affects Versions: 10.6.1.0
>         Environment: Linux machine.dom 2.6.34.1-vos #1 SMP Fri Jul 9 19:40:43 CEST 2010
x86_64 x86_64 x86_64 GNU/Linux
> java version "1.6.0_18"
> Java(TM) SE Runtime Environment (build 1.6.0_18-b07)
> Java HotSpot(TM) 64-Bit Server VM (build 16.0-b13, mixed mode)
>            Reporter: EDAH-TALLY
>             Fix For: 10.6.1.0
>
>         Attachments: derby.log, start_server.sh, sysifo.log
>
>
> Hello,
> I'm trying to implement the custom authentication provider facility of Derby and am constantly
hitting against a ClassNotFoundException.
> I created a DB on a Derby server running in ssl mode basic with no security manager.
The DB is created with the following properties : 
>         CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY('derby.connection.requireAuthentication',
'true')
>         CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY('derby.database.defaultConnectionMode',
'noAccess')
>         CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY('derby.database.propertiesOnly',
'true')
>         CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY('derby.authentication.provider',
'lab.DerbyAP')
> derby.authentication.provider points to the custom class lab.DerbyAP, which is in a jar
file on the server and in the classpath of the script starting the server (see attachement).
> When the DB is created, an authorized user can connect normally.
> If the server is shutdown and started again, no one can connect again. The database can't
be booted on account of the custom class lab.DerbyAP not being found, though it is present
and in the classpath.
> I attach also derby.log and sysinfo output or details.
> It seems that the server can't find at all a class in the classpath, or the classpath
'inside' the server does not reference the class.
> I tried also using the derby.database.classpath property after installing the jar file
containing the custom class using sqlj.install_jar, but to no avail. The ClassNotFoundException
still gets fired.
> I can't see what I'm missing, it smells like a single simple point but after three days
researching the problem... it's getting long !
> Please advse.
> Thank you.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message