db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <rick.hille...@oracle.com>
Subject Re: No suitable driver found for ...
Date Tue, 20 Jul 2010 14:01:13 GMT
Kristian Waagan wrote:
> On 20.07.10 14:55, Tiago Espinha wrote:
>> Hello all,
>>
>> I'm doing some old client testing for DERBY-4746 and I've ran into a 
>> problem
>> that I can't seem to be able to solve. Basically, I tested my trunk 
>> server
>> against a 10.5 client and everything was fine. But then when I test 
>> it against a
>> 10.1.1.0 client, I get the following:
>>
>> No suitable driver found for 
>> jdbc:derby://localhost:1527/client1011;create=true
>>
>> I'm using eclipse and I simply add all the external jars (inside the 
>> bin folder)
>> into the project. This procedure worked with 10.5 but 10.1.1.0 isn't 
>> liking it
>> for some reason. Does anyone know what might be the cause of this? I 
>> get this
>> exception just as I do:
>>
>> Connection conn =
>> DriverManager.getConnection("jdbc:derby://localhost:1527/client1011;create=true");

>>
>>    
>
> Hi Tiago,
>
> I don't know why it would be special for 10.1.1.0, but have you done 
> Class.forName("org.apache.derby.jdbc.ClientDriver")?
> Does your test code work with 10.5 if you run with Java 1.4 or 5.0?
>
> Not sure when we added the driver auto-loading.... Was it in Derby 10.3?
Driver autoloading was part of JDBC4 so we added it with the other Java 
6 support in 10.2.

Cheers,
-Rick
>
>
> Regards,


Mime
View raw message