db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kathey Marsden (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-4739) test hang in Suites.all starting derbynet.SSLTest on Mac OS X 10.6
Date Thu, 22 Jul 2010 13:07:49 GMT

    [ https://issues.apache.org/jira/browse/DERBY-4739?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12891143#action_12891143
] 

Kathey Marsden commented on DERBY-4739:
---------------------------------------

Lily and I looked at this for a few minutes the other day.  A few things we noted:
Since the test does not run with classes a work around for running Suites.All might be to
run tests with classpath set to poiint to classes instead of the jars and the test will be
skipped.

We tried to fire the test up in the debugger but since the server process is spawned we couldn't
see what was happening there. The thread dumps show that there is no DRDAConnThread on the
server side waiting to handle the request, so I am guessing some unlogged exception caused
the session creation to fail and somehow that exception was lost. In ClientThread.java it
looks like all exceptions that occur during parent.addSession(clientSocket) get caught and
reported with parent.consoleExceptionPrintTrace(ie) except but I don't know how the PrintWriter
is set for the test, so maybe are getting lost somehow.  I guess I would start with changing
consoleExceptiPrintTrace to just print to System.out to make sure no exception is lost. 



> test hang in Suites.all starting derbynet.SSLTest on Mac OS X 10.6
> ------------------------------------------------------------------
>
>                 Key: DERBY-4739
>                 URL: https://issues.apache.org/jira/browse/DERBY-4739
>             Project: Derby
>          Issue Type: Bug
>    Affects Versions: 10.7.0.0
>         Environment: Mac OS X 10.6 
> java version "1.6.0_20"
> Java(TM) SE Runtime Environment (build 1.6.0_20-b02-279-10M3065)
> Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01-279, mixed mode)
>            Reporter: Kathey Marsden
>         Attachments: sslserver52901.txt, suitesall52832.txt
>
>
> My suites.All run on OS X 10.6  hung after the following
> testSysinfoMethod used 15 ms .
> testSysinfoLocale used 447 ms 
> The following processes are running so I assume the issue is actually with SSLTest, which
is the next up.
> Katherine-Marsdens-iMac:test kmarsden$ ps -ef | grep java
>   501 53221 21233   0   0:00.00 ttys000    0:00.00 grep java
>   501 52832 52830   0   0:06.18 ttys001    0:41.73 /usr/bin/java -Dderby.tests.trace=true
-XX:MaxPermSize=128M -Xmx1024M -Xms512M -DderbyTesting.oldReleasePath=/Users/kmarsden/Derby/svn/svnreleases/jars
junit.textui.TestRunner org.apache.derbyTesting.functionTests.suites.All
>   501 52901 52832   0   0:01.57 ttys001    0:05.66 /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/bin/java
-classpath /Users/kmarsden/Derby/svn/trunk/jars/sane/derbyrun.jar:/Users/kmarsden/Derby/svn/trunk/jars/sane/derbyTesting.jar:/Users/kmarsden/Derby/svn/trunk/tools/java/junit.jar:/Users/kmarsden/Derby/svn/trunk/tools/java/jakarta-oro-2.0.8.jar
-Djavax.net.ssl.keyStore=extinout/SSLTestServerKey.key -Djavax.net.ssl.keyStorePassword=qwerty
org.apache.derby.drda.NetworkServerControl start -h localhost -p 1527 -ssl basic
> Katherine-Marsdens-iMac:test kmarsden$ 
> The derby.log which actually is in the test start directory shows the server started.
> Katherine-Marsdens-iMac:test kmarsden$ cat derby.log
> 2010-07-08 19:37:42.485 GMT : Apache Derby Network Server - 10.7.0.0 alpha - (959181M)
started and ready to accept SSL connections on port 1527
> I am trying to figure out how to get a thread dump. I have so far tried kill -QUIT and
<ctrl> \ in the terminal screen and <command> \.
> Once I get that I will try to run the test by itself.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message