db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kathey Marsden (JIRA)" <j...@apache.org>
Subject [jira] Created: (DERBY-4726) Investigate updating Junit version required for Derby build and test
Date Wed, 30 Jun 2010 16:39:49 GMT
Investigate updating Junit version required for Derby build and test

                 Key: DERBY-4726
                 URL: https://issues.apache.org/jira/browse/DERBY-4726
             Project: Derby
          Issue Type: Improvement
          Components: Build tools, Test
    Affects Versions:
            Reporter: Kathey Marsden

The derby build documentation BUILDING.html says the derby build requires JUnit 3.8.2. Junit
3.8.2 is no longer available at junit.org but can be downloaded from:


At a minimum  we need to update the download references but it would be good to move ahead
to JUnit 4 if possible., because who knows how long 3.8 will be generally available. 
 Knut mentioned the following useful history.

- It used to be that Derby wouldn't build with JUnit 4, but now it seems to, perhaps because
we require JDK 1.5 in the build.
- He thinks that  Junit 3.8.1 is still required for some small device platforms, because even
3.8.2 doesn't work there
- We recommend 3.8.2 in BUILDING.html is was that it was better on reporting errors. In particular,
failures in tearDown() don't mask failures in the test case (they did 3.8.1)

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message