db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Knut Anders Hatlen (JIRA)" <j...@apache.org>
Subject [jira] Created: (DERBY-4678) Avoid code duplication in GenericConglomerateController.fetch()
Date Wed, 26 May 2010 11:34:32 GMT
Avoid code duplication in GenericConglomerateController.fetch()

                 Key: DERBY-4678
                 URL: https://issues.apache.org/jira/browse/DERBY-4678
             Project: Derby
          Issue Type: Improvement
          Components: Store
    Affects Versions:
            Reporter: Knut Anders Hatlen
            Assignee: Knut Anders Hatlen
            Priority: Minor

GenericConglomerateController has two methods named fetch(). One of these methods has a parameter
called waitForLock, whereas the other one doesn't have such a parameter. When I diffed the
two methods, the only difference I found, apart from a couple of whitespace diffs, was that
the method with the waitForLock parameter called lockPosititionForRead/lockPositionForWrite
using the parameter value, and the other method called them with a hard-coded value of true.

To avoid duplication of code, fetch(RowLocation,DataValueDescriptor[],FormatableBitSet) should
forward calls to fetch(RowLocation,DataValueDescriptor[],FormatableBitSet,boolean).

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message