db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jayaram Subramanian <rsjay1...@gmail.com>
Subject Re: Fwd: Suites.All
Date Tue, 06 Apr 2010 10:46:27 GMT
Hi All,
As per discussion with Bryan Myrna and Kathy, I did
ant clobber,
rm -rf  jars/*
ant all
ant buildjars
java -Dderby.tests.trace=true junit.textui.TestRunner
org.apache.derbyTesting.functionTests.tests.derbynet.SysinfoTest >
runoutput.out 2>&1

It still kept giving the same issue. For debugging i decided to add
Sys.out.println's suggested by Bryan in the Sysinfotest code.But this
time when i load up the project in eclipse i am not able to see the
SysInfoTest.java file in derbynet folder in eclipse. So i am not able
to add the System.out.println statements as pointed out by Bryan. I am
attaching screenshot of my project explorer view.

With Regards
Jayaram


On Thu, Apr 1, 2010 at 9:31 PM, Jayaram Subramanian <rsjay1976@gmail.com> wrote:
>
> Hi Bryan,
> I tried the buildjars but ended up with the issue below..
>
> C:\java\derby\source\trunk\build.xml:1329: Unable to rename old file (C:\java\de
> rby\source\trunk\jars\sane\derby.jar) to temporary file
>
> I tried checking permissions on folder c:\java\source\derby\trunk but everything was
ok.
>
> With Regards
> Jayaram
>
> On Wed, Mar 31, 2010 at 8:39 AM, Bryan Pendleton <bpendleton.derby@gmail.com> wrote:
>>
>> Jayaram Subramanian wrote:
>>>
>>> Hi Bryan,
>>> I wrote the System.out.println code as suggested into SysInfoTest.java file and
tried running java -Dderby.tests.trace=true junit.textui.TestRunner org.apache.derbyTesting.functionTests.tests.derbynet.SysinfoTest
> runoutput.out 2>&1.
>>>
>>> But the System.out.println outputs never got printed on the out file. But still
i got the same Assertion errors in the out file... Since i got a doubt, i even removed the
SysInfoTest.java file from the derbynet folder and tried running the java command expecting
it to give "source not found" kind of a issue. But still the java command ran and gave the
same errors as noted earlier. Is the file cached somewhere else in the system. I tried doing
a search but could locate only 1 existance of the file in derbynet folder.
>>
>> junit will run the class from your class path, so use:
>>
>>  echo $CLASSPATH
>>
>> to figure out where your classpath is pointing.
>>
>> After modifying SysInfoTest.java, you'll need to do:
>>
>>  ant all
>>
>> and, if your classpath is pointing at the jar files:
>>
>>  ant buildjars
>>
>> You should definitely see your print statements in the output of your junit test
>> command, and the syntax of your junit test command looks fine to me, so I
>> suspect this is just a build problem.
>>
>> thanks,
>>
>> bryan
>

Mime
View raw message