db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <rick.hille...@oracle.com>
Subject Re: VTI tables
Date Wed, 21 Apr 2010 16:31:53 GMT
Ян Программист wrote:
> I propose to create a ticket in JIRA for providing *.diag (VTI) 
> classes conformance against Java 6. Currently compiler reports too lot 
> of warnings. John 
Hi John

We can't compile these classes against Java 6 because the byte code 
would only run on Java 5 or higher. We still expect that Derby will run 
on jdk 1.4. The community could, of course, discuss whether we want to 
continue supporting jdk 1.4. I suspect that the answer is yes. That is 
because 1.4 is the level used by the CDC small device platforms.

Regards,
-Rick

Mime
View raw message