db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myrna van Lunteren (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-4038) On Z/OS store/access.sql fails with encryptionAES and encryptionDES
Date Tue, 17 Nov 2009 17:55:40 GMT

    [ https://issues.apache.org/jira/browse/DERBY-4038?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12779014#action_12779014
] 

Myrna van Lunteren commented on DERBY-4038:
-------------------------------------------

I have played with this for a while, and I've come to 3 conclusions:
1. Knut is right, it seems the only diff is that in some parts of the runtime statistics output
the tabs have been replaced by another character
2. This is intermittent.
 Kathey reported the failure in the platform tests for 10.5.1.0 and 10.5.1.1 but not for (the
discarded) 10.5.2.0.
I ran encryptionAll on a zseries machine a couple of times and never got a failure. I ran
derbyall a couple of times and access.sql failed once in encryptionBlowfish - with the character-replacement
happening in about 18 instances (as opposed to 7 in the log Kathey attached).
3. the diff output created by the test is singularly unhelpful.

It's possible there's something wrong with the generateUTF8OutFile code in functionTests.harness.RunTest;
I'm not sure why that would be intermittent though.
One way to fix this would be to convert the test to junit.


> On Z/OS store/access.sql fails with encryptionAES and encryptionDES
> -------------------------------------------------------------------
>
>                 Key: DERBY-4038
>                 URL: https://issues.apache.org/jira/browse/DERBY-4038
>             Project: Derby
>          Issue Type: Bug
>          Components: Test
>    Affects Versions: 10.3.3.0
>         Environment: java version "1.6.0"
> Java(TM) SE Runtime Environment (build pmz6460sr3-20081108_01(SR3))
> IBM J9 VM (build 2.4, J2RE 1.6.0 IBM J9 2.4 z/OS s390x-64 jvmmz6460-20081107_25433 (JIT
enabled, AOT enabled)
> J9VM - 20081105_025433_BHdSMr
> JIT  - r9_20081031_1330
> GC   - 20081027_AB)
> JCL  - 20081106_01
> $ pwd
>            Reporter: Kathey Marsden
>            Priority: Minor
>         Attachments: access.diff, access.out
>
>
> On Z/OS access.sql fails for encryptionAES and encryptionDES. The diff is big but I can't
quite make out what the problem is. Maybe just a change of query plans.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message