db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kristian Waagan (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DERBY-4267) Investigate why Derby 10.5.1.1 is not available in the maven2 repositories
Date Tue, 06 Oct 2009 13:09:31 GMT

     [ https://issues.apache.org/jira/browse/DERBY-4267?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kristian Waagan updated DERBY-4267:
-----------------------------------

    Attachment: derby-4267-2c-using_ant_task.diff

Attached patch 2c, which contains the following changes:
 - removed the now unused derby.version property.
 - replaced '${derby.version}' with 'ALPHA_VERSION' as a placeholder. Replace with the correct
Derby version before installing / deploying.
 - added workaround for a bug in the install plugin by requiring a newer version of the plugin.
This should be removed at a later time. The bug caused the checksums for derby-project-VERSION.pom
to not be generated.


Hi Rick,

As you can see above, investigation showed that the reported checksum problem above was caused
by a bug in maven-install-plugin. Please give patch 2c a try, or simply add the few lines
required from the top level POM to you own environment (in case you want to change as little
as possible).

After you have test-driven patch 2c, I plan to commit it.

One issue remains (I brought it up before):
Do we want to point to the 10.5 branch, or to trunk in the source code repository property
for 10.5?
Currently it points at trunk, but that can easily be changed in the top level POM (see the
scm tag).

> Investigate why Derby 10.5.1.1 is not available in the maven2 repositories
> --------------------------------------------------------------------------
>
>                 Key: DERBY-4267
>                 URL: https://issues.apache.org/jira/browse/DERBY-4267
>             Project: Derby
>          Issue Type: Task
>          Components: Build tools
>    Affects Versions: 10.5.1.1, 10.6.0.0
>            Reporter: H.-Dirk Schmitt
>         Attachments: derby-4267-1a-maven2.diff, derby-4267-1a-maven2.stat, derby-4267-2a-using_ant_task.diff,
derby-4267-2a-using_ant_task.stat, derby-4267-2b-using_ant_task.diff, derby-4267-2b-using_ant_task.stat,
derby-4267-2c-using_ant_task.diff, maven2.zip
>
>
> Only 10.4.2.0 and older are available in the maven 2 repositories.
> May you please also provide the new version.
> Please see also https://issues.apache.org/jira/browse/DERBY-4220

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message