db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kristian Waagan (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-4267) Investigate why Derby 10.5.1.1 is not available in the maven2 repositories
Date Fri, 18 Sep 2009 09:24:57 GMT

    [ https://issues.apache.org/jira/browse/DERBY-4267?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12757075#action_12757075
] 

Kristian Waagan commented on DERBY-4267:
----------------------------------------

Hi all,

I'm still on sick leave, and is restricted to typing with one arm only, but I thought I should
share a few of my thoughts on this issue.
After searching the Maven forums, it appears I have led us into one of Maven's quagmires.
What I instinctively tried to do (I haven't used Maven before), isn't yet supported and it
seems fixing it isn't straight forward. The limitation/problem has been known for quite some
time.
Due to a reboot I managed to loose my references to the relevant JIRAs, but I can dig them
up again later.

I suggest we take action to fix the problem our users are experiencing by inserting the version
in the POM "manually". Since there are quite a few POMs to edit, maybe inserting a placeholder
would be good? Then people can use whichever tool they're familiar with on their platform
to replace the placeholder with an actual version (on *nix this could be perl or sed).

Note that the already deployed POMs shouldn't be edited, because that would mess up the checksums.

> Investigate why Derby 10.5.1.1 is not available in the maven2 repositories
> --------------------------------------------------------------------------
>
>                 Key: DERBY-4267
>                 URL: https://issues.apache.org/jira/browse/DERBY-4267
>             Project: Derby
>          Issue Type: Task
>          Components: Build tools
>    Affects Versions: 10.5.1.1, 10.6.0.0
>            Reporter: H.-Dirk Schmitt
>         Attachments: derby-4267-1a-maven2.diff, derby-4267-1a-maven2.stat, derby-4267-2a-using_ant_task.diff,
derby-4267-2a-using_ant_task.stat, derby-4267-2b-using_ant_task.diff, derby-4267-2b-using_ant_task.stat,
maven2.zip
>
>
> Only 10.4.2.0 and older are available in the maven 2 repositories.
> May you please also provide the new version.
> Please see also https://issues.apache.org/jira/browse/DERBY-4220

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message