db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rick Hillegas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-4267) Investigate why Derby 10.5.1.1 is not available in the maven2 repositories
Date Thu, 10 Sep 2009 19:28:58 GMT

    [ https://issues.apache.org/jira/browse/DERBY-4267?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12753778#action_12753778
] 

Rick Hillegas commented on DERBY-4267:
--------------------------------------

I tried using the patch to deploy to the maven2 repository, but was stymied by authentication
problems. I issued the following command:

mvn "-Dgpg.passphrase=$PASSPHRASE" -Dderby.version=10.5.3.0 -Dmy_login=rhillegas -Dmy_password=$APACHE_PASSWORD
clean deploy

I also tried leaving off the login and password properties and, instead, hardwiring them into
settings.xml. In both cases, deployment failed with the following exception:

[INFO] Error deploying artifact: Authentication failed: Cannot connect. Reason: Algorithm
negotiation fail

Based on my bad experience with deployment under maven1, I abandoned this approach. Instead,
I tar'd up the artifacts, copied the tarball to people.apache.org and untar'd the contents
under /www/people.apache.org/repo/m2-ibiblio-rsync-repository/org/apache I changed the group
ownership of the artifacts to apcvs and gave the group write access to the top level directory.

> Investigate why Derby 10.5.1.1 is not available in the maven2 repositories
> --------------------------------------------------------------------------
>
>                 Key: DERBY-4267
>                 URL: https://issues.apache.org/jira/browse/DERBY-4267
>             Project: Derby
>          Issue Type: Task
>          Components: Build tools
>    Affects Versions: 10.5.1.1, 10.6.0.0
>            Reporter: H.-Dirk Schmitt
>         Attachments: derby-4267-1a-maven2.diff, derby-4267-1a-maven2.stat, derby-4267-2a-using_ant_task.diff,
derby-4267-2a-using_ant_task.stat, derby-4267-2b-using_ant_task.diff, derby-4267-2b-using_ant_task.stat,
maven2.zip
>
>
> Only 10.4.2.0 and older are available in the maven 2 repositories.
> May you please also provide the new version.
> Please see also https://issues.apache.org/jira/browse/DERBY-4220

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message