db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kristian Waagan (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-4267) Investigate why Derby 10.5.1.1 is not available in the maven2 repositories
Date Sat, 01 Aug 2009 17:20:14 GMT

    [ https://issues.apache.org/jira/browse/DERBY-4267?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12737916#action_12737916
] 

Kristian Waagan commented on DERBY-4267:
----------------------------------------

Dag, 

Thanks for looking at the patch. Regarding your questions:
a) mvn install: Yes, this must be run from withing the maven2 directory.
b) Correct, the version is inherited and set in the parent pom ("derby-project").
c) filtering: You are correct it should be turned off, if we continue to use this plugin.

Regarding the warning messages you see, I think they are coming from jar:jar (jar-default),
as I have set the encoding for the resources plugin.
However, I have obviously failed to instruct maven to add the Derby jar files. We're not following
Maven conventions, because we're not using it to build the artifacts. All that is needed is
to tell Maven to use the pre-built jar as the artifact.

The only way I have managed to do this so far, is to use the antrun plugin with the ant copy
task. It is more of a hack though, since I'm overwriting the artifact built by Maven itself
(which is the almost empty jar you're mentioning, containing some metadata).

Unless anybody gives me a hint, or provides a better solution, I'm going to add the other
dependencies and switch to using the antrun task.
Also, is there a way to make Maven2 not execute or not try to package anything for the jar:jar
goal?


Help from an experienced Maven2 user would be nice at this point! Help from not-so-experienced
users is also welcome ;)

> Investigate why Derby 10.5.1.1 is not available in the maven2 repositories
> --------------------------------------------------------------------------
>
>                 Key: DERBY-4267
>                 URL: https://issues.apache.org/jira/browse/DERBY-4267
>             Project: Derby
>          Issue Type: Task
>          Components: Build tools
>    Affects Versions: 10.5.1.1, 10.6.0.0
>            Reporter: H.-Dirk Schmitt
>         Attachments: derby-4267-1a-maven2.diff, derby-4267-1a-maven2.stat, maven2.zip
>
>
> Only 10.4.2.0 and older are available in the maven 2 repositories.
> May you please also provide the new version.
> Please see also https://issues.apache.org/jira/browse/DERBY-4220

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message