db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julien HENRY (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (DERBY-4267) Investigate why Derby 10.5.1.1 is not available in the maven2 repositories
Date Tue, 25 Aug 2009 13:43:59 GMT

    [ https://issues.apache.org/jira/browse/DERBY-4267?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12747407#action_12747407
] 

Julien HENRY edited comment on DERBY-4267 at 8/25/09 6:42 AM:
--------------------------------------------------------------

To suppress
[WARNING] Using platform encoding (UTF-8 actually) to copy filtered resources, i.e. build
is platform dependent!

you simply have to define the encoding of your files and set the following property in the
POM.

{code:xml}
<properties>
    <!-- All plugins should use this value. See http://docs.codehaus.org/display/MAVENUSER/POM+Element+for+Source+File+Encoding
-->
        <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
</properties>
{code}

this is a standardized Maven properties that all plugins will use except compiler plugin that
is not yet released.

      was (Author: henryju):
    To suppress
[WARNING] Using platform encoding (UTF-8 actually) to copy filtered resources, i.e. build
is platform dependent!

you simply have to define the encoding of your files and set the following property in the
POM.

{code}
<properties>
    <!-- All plugins should use this value. See http://docs.codehaus.org/display/MAVENUSER/POM+Element+for+Source+File+Encoding
-->
        <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
</properties>
{code}

this is a standardized Maven properties that all plugins will use except compiler plugin that
is not yet released.
  
> Investigate why Derby 10.5.1.1 is not available in the maven2 repositories
> --------------------------------------------------------------------------
>
>                 Key: DERBY-4267
>                 URL: https://issues.apache.org/jira/browse/DERBY-4267
>             Project: Derby
>          Issue Type: Task
>          Components: Build tools
>    Affects Versions: 10.5.1.1, 10.6.0.0
>            Reporter: H.-Dirk Schmitt
>         Attachments: derby-4267-1a-maven2.diff, derby-4267-1a-maven2.stat, derby-4267-2a-using_ant_task.diff,
derby-4267-2a-using_ant_task.stat, maven2.zip
>
>
> Only 10.4.2.0 and older are available in the maven 2 repositories.
> May you please also provide the new version.
> Please see also https://issues.apache.org/jira/browse/DERBY-4220

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message