db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dag H. Wanvik (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DERBY-4296) Derby should require EXECUTE privilege on SYSCS_UTIL.SYSCS_INPLACE_COMPRESS_TABLE before allowing users to execute it
Date Fri, 03 Jul 2009 13:26:48 GMT

     [ https://issues.apache.org/jira/browse/DERBY-4296?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dag H. Wanvik updated DERBY-4296:
---------------------------------

    Bug behavior facts: [Security]

Checked "Security".

> Derby should require EXECUTE privilege on SYSCS_UTIL.SYSCS_INPLACE_COMPRESS_TABLE before
allowing users to execute it
> ---------------------------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-4296
>                 URL: https://issues.apache.org/jira/browse/DERBY-4296
>             Project: Derby
>          Issue Type: Bug
>          Components: SQL
>            Reporter: Mamta A. Satoor
>
> While researching on DERBY-4295, I found that Derby is not requiring a user to have execute
privileges on SYSCS_UTIL.SYSCS_INPLACE_COMPRESS_TABLE which I think should be required before
a user can use it to try compressing a table. At least, that is what we require for SYSCS_UTIL.SYSCS_EXPORT_TABLE.
May be there are other procedures too for which we do not do this check. That research can
be done when we decide to fix this jira entry.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message