db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kathey Marsden (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-4267) Investigate why Derby 10.5.1.1 is not available in the maven2 repositories
Date Wed, 29 Jul 2009 21:59:14 GMT

    [ https://issues.apache.org/jira/browse/DERBY-4267?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12736860#action_12736860
] 

Kathey Marsden commented on DERBY-4267:
---------------------------------------

Hi Kristian, I would like to try to get maven2 updated for the 10.5.2 release. I would like
to do whatever I can to help get the procedure finalized, but don't feel at all qualified
to answer your questions or review the patch. I will download it and give it a try. Meanwhile
here is my feeble input on some of your questions:
b) Do we want to keep the M1 stuff around?
If we can avoid it I think that would be good. I would say lets just publish maven2 for 10.5.2
and see if anyone complains.
c) Where do we put the new files?
Does /trunk/maven2 seem like a good place?
d) I have defined a dependency between derbynet and derby. Are there more dependencies we
should add?
I am not sure what the dependency relationship means but there is definitely a relationship
between the locale jars and derby.jar and derbyrun.jar and the other jars.

e) Do we want to publish derbyTesting?
I think it would be useful but don't know if it causes problems for those that download all
the jars. Would there be a problem with footprint? I don't think we published it with maven1.

f) When publishing a new release, should we update the SubVersion repos URL to be the branch
instead of trunk?
I think that makes sense.



> Investigate why Derby 10.5.1.1 is not available in the maven2 repositories
> --------------------------------------------------------------------------
>
>                 Key: DERBY-4267
>                 URL: https://issues.apache.org/jira/browse/DERBY-4267
>             Project: Derby
>          Issue Type: Task
>          Components: Build tools
>    Affects Versions: 10.5.1.1, 10.6.0.0
>            Reporter: H.-Dirk Schmitt
>         Attachments: maven2.zip
>
>
> Only 10.4.2.0 and older are available in the maven 2 repositories.
> May you please also provide the new version.
> Please see also https://issues.apache.org/jira/browse/DERBY-4220

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message