db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knut Anders Hatlen <Knut.Hat...@Sun.COM>
Subject Re: Help with build issue
Date Mon, 08 Jun 2009 23:29:41 GMT
Knut Anders Hatlen <Knut.Hatlen@Sun.COM> writes:

> Since Derby's build script is supposed to do the right thing with the
> classpath if it only finds JDK 6, you may have more luck if you try
> again with only this in ant.properties:
>
> jdk16=c:/sun/sdk/jdk
> j16lib=${jdk16}/jre/lib
>
> But with your setup this shold have been detected automatically.

It looks like we only detect that it's JDK 6 if the directory in which
it is installed contains the string "1.6". I have logged this as a bug
here: https://issues.apache.org/jira/browse/DERBY-4263

For now, setting (only) j16lib as described above or renaming your jdk
directory to jdk1.6.0 should make it build.

Hope this helps,

-- 
Knut Anders

Mime
View raw message