db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lily Wei <lily...@yahoo.com>
Subject Help with build issue
Date Mon, 08 Jun 2009 21:29:39 GMT
Hi:
     I am trying to build trunk with sun JDK 1.6, ANT 1.7.1 and junit 3.8.2.

     I am getting error like:
c:\derby\10.5\build.xml:203: Don't know how to set java15compile.classpath, java
16compile.classpath using this environment:
java.vendor = Sun Microsystems Inc.
java.home = c:\sun\sdk\jdk\jre
java.version = 1.6.0_13
os.name = Windows Vista
j14lib = null
j15lib = null
j16lib = null
Please consult BUILDING.html for instructions on how to set the compiler-classpa
th properties.

     After setting ant.properties under my user directionry like:
bash-3.1$ cat ant.properties
jdk16=c:/sun/sdk/jdk
j16lib=${jdk16}/jre/lib
j14lib=${jdk16}/jre/lib
j15lib=${jdk16}/jre/lib

     I get a different error. The error is relate to XPath.class:
compile_types:
    [javac] org\apache\derby\iapi\types\SqlXmlUtil.java added as org\apache\derb
y\iapi\types\SqlXmlUtil.class doesn't exist.
    [javac] Compiling 1 source file to c:\derby\trunk\classes
    [javac] Using modern compiler
    [javac] Compilation arguments:
    [javac] '-nowarn'
    [javac] '-deprecation'
    [javac] '-d'
    [javac] 'c:\derby\trunk\classes'
    [javac] '-classpath'
    [javac] 'c:\derby\trunk\classes;c:\sun\sdk\jdk\jre\lib\charsets.jar;c:\sun\s
dk\jdk\jre\lib\deploy.jar;c:\sun\sdk\jdk\jre\lib\javaws.jar;c:\sun\sdk\jdk\jre\l
ib\jce.jar;c:\sun\sdk\jdk\jre\lib\jsse.jar;c:\sun\sdk\jdk\jre\lib\management-age
nt.jar;c:\sun\sdk\jdk\jre\lib\plugin.jar;c:\sun\sdk\jdk\jre\lib\resources.jar;c:
\sun\sdk\jdk\jre\lib\rt.jar;c:\derby\trunk\tools\java\xercesImpl.jar'
    [javac] '-sourcepath'
    [javac] 'c:\derby\trunk\java\engine'
    [javac] '-target'
    [javac] '1.4'
    [javac] '-bootclasspath'
    [javac] 'c:\derby\trunk\classes\empty'
    [javac] '-g'
    [javac] '-source'
    [javac] '1.4'
    [javac]
    [javac] The ' characters around the executable and arguments are
    [javac] not part of the command.
    [javac] File to be compiled:
    [javac]     c:\derby\trunk\java\engine\org\apache\derby\iapi\types\SqlXmlUti
l.java
    [javac] c:\derby\trunk\java\engine\org\apache\derby\iapi\types\SqlXmlUtil.ja
va:60: package org.apache.xpath does not exist
    [javac] import org.apache.xpath.XPath;
    [javac]                        ^
    [javac] c:\derby\trunk\java\engine\org\apache\derby\iapi\types\SqlXmlUtil.ja
va:61: package org.apache.xpath does not exist
    [javac] import org.apache.xpath.XPathContext;

    I notice xalan.jar where org.apache.xpath.XPath is not in my class list. Any idea what
the problem might be.

Thank you so much,
Lily



      
Mime
View raw message