db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dag H. Wanvik (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DERBY-4045) Subquery causes error: 'updateString' not allowed because the ResultSet is not an updatable ResultSet
Date Fri, 26 Jun 2009 19:53:47 GMT

     [ https://issues.apache.org/jira/browse/DERBY-4045?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dag H. Wanvik updated DERBY-4045:
---------------------------------

    Derby Categories:   (was: [Wrong query result])

Removing "wrong query result" flag because the case here is a limitation, not wrong data returned
from a query.


> Subquery causes error: 'updateString' not allowed because the ResultSet is not an updatable
ResultSet
> -----------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-4045
>                 URL: https://issues.apache.org/jira/browse/DERBY-4045
>             Project: Derby
>          Issue Type: Bug
>          Components: SQL
>            Reporter: John T. Dow
>
> Embedded Derby (don't know about client) demoted an updatable result set apparently due
to a nested query.
> select * from orders where (orders.recordno = (select max(orders.recordno) from orders))
> Fix if possible. 
> If it can't be fixed, the documentation should be changed.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message