db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kim Haase <Camilla.Ha...@Sun.COM>
Subject Re: Documentation build error
Date Mon, 09 Feb 2009 21:50:49 GMT
On 02/09/09 13:29, Knut Anders Hatlen wrote:
> Bryan Pendleton <bpendleton@amberpoint.com> writes:
> 
>>> /home2/bpendleton/src/derby/docs/trunk/DITA-OT1.1.2.1/pretargets.xml:136:
>>> javax.xml.transform.TransformerException:
>>> java.lang.NullPointerException
>> I think the problem was that I was running JDK 1.5, and the documentation
>> build appears to ONLY work with JDK 1.4. After I fully reset my environment
>> to JDK 1.4 (both PATH and JAVA_HOME), the build seems to run successfully.
> 
> Hi Bryan,
> 
> Andrew suggested that this problem would go away if you put the Xalan
> jars in the classpath.
> 
> http://mail-archives.apache.org/mod_mbox/db-derby-dev/200702.mbox/%3c54ac72d70702261117m1599a516n30d4a8be51bc520b@mail.gmail.com%3e
> 
> By the way, I vaguely recall that we did some work to get the docs to
> build with DITA 1.2. Have you tried upgrading it?
> 
That would be an interesting experiment. Actually Andrew McIntyre did 
some work to get Derby to build with DITA 1.3 and a newer version of 
FOP, but I'm not sure it worked. We would probably need an expert like 
Andrew to do some tweaking of the Derby files to make the build work 
right. I think he made some progress -- see DERBY-2373 -- but I'm not 
sure it has been followed up on.

DITA is now at 1.4.

Kim

Mime
View raw message