db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knut Anders Hatlen <Knut.Hat...@Sun.COM>
Subject Re: derby release 10.1.3.1 --> 10.4.1.3
Date Mon, 19 Jan 2009 12:50:03 GMT
Peter Wissel <pwissel@brox.de> writes:

> Hi derby team,
>
> I have a question about different versions of derby.
>
> Currently we are using derby-10.1.3.1 in the SMILA-project.
>
> Now we plan to replace derby-10.1.3.1 with a newer release of derby
> (10.4.1.3).
>
> My question is, if it is possible to replace the org.apache.derby.jar without
> incompatibilities?

Hi Peter,

There are some incompatibilities that have been introduced
intentionally. These have been documented in the release
notes. Unfortunately, you'll have to go through the notes for all
releases between the one one you're going from and the one you're going
to. Here are the ones describing potential incompatibilities between
10.1.3.1 and the current 10.4.2.0 release:

Differences between 10.1.3.1 and 10.2.1.6:
http://db.apache.org/derby/releases/release-10.2.1.6.html

Differences between 10.2.1.6 and 10.2.2.0:
http://db.apache.org/derby/releases/release-10.2.2.0.html

Differences between 10.2.2.0 and 10.3.1.4:
https://svn.apache.org/viewvc/db/derby/code/tags/10.3.1.4/RELEASE-NOTES.html?view=co

Differences between 10.3.1.4 and 10.3.2.1:
https://svn.apache.org/viewvc/db/derby/code/tags/10.3.2.1/RELEASE-NOTES.html?view=co

Differences between 10.3.2.1 and 10.4.1.3:
http://db.apache.org/derby/releases/release-10.4.1.3.html

Differences between 10.4.1.3 and 10.4.2.0:
http://db.apache.org/derby/releases/release-10.4.2.0.cgi

-- 
Knut Anders

Mime
View raw message