db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <Richard.Hille...@Sun.COM>
Subject JDK 1.4 support
Date Mon, 01 Dec 2008 14:32:09 GMT
The user list has been discussing Derby's future support for JDK 1.4: 
http://www.nabble.com/JDK-1.4-support--td20650279.html#a20650279 I am 
moving that thread over to the developer list now.

Dag and Knut have raised the issue of small device support. BUILDING.txt 
suggests that Derby will run on CDC/Foundation Profile 1.0. I don't 
believe that's true anymore. I think that we abandoned CDC/FP 1.0 when 
we abandoned JDK 1.3. For the last couple releases, I believe that we 
have only been claiming that Derby will run on CDC/FP 1.1.2. That api is 
a subset of JDK 1.4.2 (see for instance 
http://java.sun.com/products/foundation/ ).

Our current small device claims aren't based on compile-time checks. 
Instead, we rely on warnings raised by community members who run the 
tests on small platforms. If we want to continue supporting small 
devices, then I think that we ought to be compiling the bulk of the core 
engine against CDC/FP 1.1.2 libraries, not against JDK 1.4.2 libraries.

Regards,
-Rick

Mime
View raw message