db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rick Hillegas (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (DERBY-3966) Do not require JRE 1.4 libraries at compile time since SUN's JDK 1.4 went out of support and can be used on JRE 1.4 without any problem
Date Tue, 09 Dec 2008 20:21:44 GMT

    [ https://issues.apache.org/jira/browse/DERBY-3966?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12654941#action_12654941
] 

rhillegas edited comment on DERBY-3966 at 12/9/08 12:20 PM:
----------------------------------------------------------------

Attaching derby-3966-02-aa-buildTools.diff. This patch changes the build to use the Java 5
libraries instead of the jdk1.4 libraries when compiling the build tools used by later stages
of the Derby build. The classes are still compiled into 1.4 byte code. This change should
only affect the Derby build process itself and not the actual product jar files.

This change is the recommended workaround for the fact that our javadoc-building tools rely
on Sun-supplied Taglet classes. This issue was discussed in the following email thread:

  http://www.nabble.com/Sun-classes-imported-by-Derby-code-td17566526.html

Unless someone objects, I'm inclined to check this patch in soon.

Touches the following file:

M      java/build/org/apache/derbyBuild/build.xml


      was (Author: rhillegas):
    Attaching derby-3966-02-aa-buildTools.diff. This patch changes the build to use the Java
5 compiler instead of the jdk1.4 compiler when compiling the build tools used by later stages
of the Derby build. The classes are still compiled into 1.4 byte code. This change should
only affect the Derby build process itself and not the actual product jar files.

This change is the recommended workaround for the fact that our javadoc-building tools rely
on Sun-supplied Taglet classes. This issue was discussed in the following email thread:

  http://www.nabble.com/Sun-classes-imported-by-Derby-code-td17566526.html

Unless someone objects, I'm inclined to check this patch in soon.

Touches the following file:

M      java/build/org/apache/derbyBuild/build.xml

  
> Do not require JRE 1.4 libraries at compile time since SUN's JDK 1.4 went out of support
and can be used on JRE 1.4 without any problem
> ---------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-3966
>                 URL: https://issues.apache.org/jira/browse/DERBY-3966
>             Project: Derby
>          Issue Type: Task
>          Components: Build tools
>            Reporter: Pedro Faundez Gonzalez
>         Attachments: derby-3966-01-aa-jdbc3stubs.diff, derby-3966-01-ab-jdbc3jdbc4stubs.diff,
derby-3966-01-ac-jdbc3jdbc4stubs.diff, derby-3966-02-aa-buildTools.diff
>
>
> In the "JDK 1.4 support" conversation at Derby Users:
> http://www.nabble.com/JDK-1.4-support--td20650279.html
> I made a point that JRE 1.4 should not be required for build since SUN's JRE 1.4 went
End Of Life.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message