db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Knut Anders Hatlen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-3966) Do not require JRE 1.4 libraries at compile time since SUN's JDK 1.4 went out of support and can be used on JRE 1.4 without any problem
Date Fri, 12 Dec 2008 19:13:44 GMT

    [ https://issues.apache.org/jira/browse/DERBY-3966?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12656120#action_12656120
] 

Knut Anders Hatlen commented on DERBY-3966:
-------------------------------------------

+1 to a create new JIRA to make it possible to compile with JDK 6 only. I think we have achieved
the goal of this issue now.

I'm not sure we should set java16compile.classpath from java15compile.classpath if we don't
have JDK 6, though, as that would limit our ability to use Java SE 6 features in code that's
only supposed to run on Java SE 6

And I agree with your interpretation that we should have parts of the contents of Xalan's
NOTICE file in our NOTICE file. ("Parts of" because some sections of Xalan's NOTICE file only
apply to jar files that we don't redistribute.)

> Do not require JRE 1.4 libraries at compile time since SUN's JDK 1.4 went out of support
and can be used on JRE 1.4 without any problem
> ---------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-3966
>                 URL: https://issues.apache.org/jira/browse/DERBY-3966
>             Project: Derby
>          Issue Type: Task
>          Components: Build tools
>            Reporter: Pedro Faundez Gonzalez
>         Attachments: derby-3966-01-aa-jdbc3stubs.diff, derby-3966-01-ab-jdbc3jdbc4stubs.diff,
derby-3966-01-ac-jdbc3jdbc4stubs.diff, derby-3966-02-aa-buildTools.diff, derby-3966-03-aa-notice.diff,
derby-3966-04-aa-missingJDK14.diff, derby-3966-05-aa-notice.diff
>
>
> In the "JDK 1.4 support" conversation at Derby Users:
> http://www.nabble.com/JDK-1.4-support--td20650279.html
> I made a point that JRE 1.4 should not be required for build since SUN's JRE 1.4 went
End Of Life.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message