db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Knut Anders Hatlen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-3966) Do not require JRE 1.4 libraries at compile time since SUN's JDK 1.4 went out of support and can be used on JRE 1.4 without any problem
Date Mon, 08 Dec 2008 16:34:44 GMT

    [ https://issues.apache.org/jira/browse/DERBY-3966?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12654453#action_12654453
] 

Knut Anders Hatlen commented on DERBY-3966:
-------------------------------------------

I think there's one issue that we haven't discussed. The current build system depends on Xalan
being available in the compile classpath. Sun's class library uses Xalan internally, and therefore
comes with the Xalan classes, but the classes were moved to another package in J2SE 5.0. See
http://java.sun.com/j2se/1.5.0/compatibility.html#4740355. So we need to find a way to compile
Derby when we won't find Xalan in the standard class library. I think the only class that
needs Xalan in order to compile is o.a.d.iapi.types.SqlXmlUtil. I think we have these alternatives:

  - bundle Xalan (either binary or source, it's Apache so it should be fine)
  - rewrite SqlXmlUtil to use the standard interfaces (haven't investigated if this is possible)

> Do not require JRE 1.4 libraries at compile time since SUN's JDK 1.4 went out of support
and can be used on JRE 1.4 without any problem
> ---------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-3966
>                 URL: https://issues.apache.org/jira/browse/DERBY-3966
>             Project: Derby
>          Issue Type: Task
>          Components: Build tools
>            Reporter: Pedro Faundez Gonzalez
>         Attachments: derby-3966-01-aa-jdbc3stubs.diff, derby-3966-01-ab-jdbc3jdbc4stubs.diff
>
>
> In the "JDK 1.4 support" conversation at Derby Users:
> http://www.nabble.com/JDK-1.4-support--td20650279.html
> I made a point that JRE 1.4 should not be required for build since SUN's JRE 1.4 went
End Of Life.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message