db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rick Hillegas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-3966) Do not require JRE 1.4 libraries at compile time since SUN's JDK 1.4 went out of support and can be used on JRE 1.4 without any problem
Date Wed, 10 Dec 2008 15:32:44 GMT

    [ https://issues.apache.org/jira/browse/DERBY-3966?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12655243#action_12655243
] 

Rick Hillegas commented on DERBY-3966:
--------------------------------------

Hi Knut,

Thanks for the great feedback and thanks for fixing the build problem. After taking a walk
yesterday, I cleared my head out and came to conclusions similar to yours. Don't be alarmed,
I'm not planning to introduce another pile of stubs.

I agree that my experiments suggest some other, orthogonal JIRAs, which I will log. I agree
that the endpoint of this JIRA is to remove our build dependency on JDK1.4. I think we need
the following other JIRAs:

1) A small device doc issue: We should explicitly call out the features which we don't expect
will work on small device platforms.

2) A small device build issue: Distinguish the build targets which really require JDK1.4 from
the ones which only require the small device libraries.

I think that defaulting java14compile.classpath to java15compile.classpath (plus some extra
jars) will probably do the trick for this JIRA.

> Do not require JRE 1.4 libraries at compile time since SUN's JDK 1.4 went out of support
and can be used on JRE 1.4 without any problem
> ---------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-3966
>                 URL: https://issues.apache.org/jira/browse/DERBY-3966
>             Project: Derby
>          Issue Type: Task
>          Components: Build tools
>            Reporter: Pedro Faundez Gonzalez
>         Attachments: derby-3966-01-aa-jdbc3stubs.diff, derby-3966-01-ab-jdbc3jdbc4stubs.diff,
derby-3966-01-ac-jdbc3jdbc4stubs.diff, derby-3966-02-aa-buildTools.diff
>
>
> In the "JDK 1.4 support" conversation at Derby Users:
> http://www.nabble.com/JDK-1.4-support--td20650279.html
> I made a point that JRE 1.4 should not be required for build since SUN's JRE 1.4 went
End Of Life.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message