db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kathey Marsden (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DERBY-3972) Update test harness to run with DesktopEE JRE
Date Wed, 03 Dec 2008 17:23:44 GMT

     [ https://issues.apache.org/jira/browse/DERBY-3972?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kathey Marsden updated DERBY-3972:
----------------------------------

    Description: 
IBM's Lotus Expeditor (http://www-01.ibm.com/software/lotus/products/expeditor/) includes
the DesktopEE JRE which is described as:

"The default Java™ Runtime Environment (JRE) of Lotus Expeditor is IBM's J9 VM with the
DesktopEE class libraries, an IBM-optimized subset of Java 5 that offers a smaller footprint
and faster class loading than standard Java Runtime Environments."

My understanding is that it is a superset of JDK 1.4, so should run fine with Derby.   The
test harness needs to be updated to recognize this JVM so we can test with it.  

See 
http://publib.boulder.ibm.com/infocenter/ledoc/v6r2/topic/com.ibm.rcp.tools.doc.appdev/devapps_developingwiththejcldesktopjre.html
for more information on DesktopEE.

    Environment:     (was: IBM's Lotus Expeditor (http://www-01.ibm.com/software/lotus/products/expeditor/)
includes the DesktopEE JRE which is described as:

"The default Java™ Runtime Environment (JRE) of Lotus Expeditor is IBM's J9 VM with the
DesktopEE class libraries, an IBM-optimized subset of Java 5 that offers a smaller footprint
and faster class loading than standard Java Runtime Environments."

My understanding is that it is a superset of JDK 1.4, so should run fine with Derby.   The
test harness needs to be updated to recognize this JVM so we can test with it.  

See 
http://publib.boulder.ibm.com/infocenter/ledoc/v6r2/topic/com.ibm.rcp.tools.doc.appdev/devapps_developingwiththejcldesktopjre.html
for more information on DesktopEE.
)

> Update test harness to run with DesktopEE JRE
> ---------------------------------------------
>
>                 Key: DERBY-3972
>                 URL: https://issues.apache.org/jira/browse/DERBY-3972
>             Project: Derby
>          Issue Type: Improvement
>          Components: Test
>    Affects Versions: 10.3.3.0, 10.4.1.3, 10.5.0.0
>            Reporter: Kathey Marsden
>            Assignee: Kathey Marsden
>            Priority: Minor
>
> IBM's Lotus Expeditor (http://www-01.ibm.com/software/lotus/products/expeditor/) includes
the DesktopEE JRE which is described as:
> "The default Java™ Runtime Environment (JRE) of Lotus Expeditor is IBM's J9 VM with
the DesktopEE class libraries, an IBM-optimized subset of Java 5 that offers a smaller footprint
and faster class loading than standard Java Runtime Environments."
> My understanding is that it is a superset of JDK 1.4, so should run fine with Derby.
  The test harness needs to be updated to recognize this JVM so we can test with it.  
> See 
> http://publib.boulder.ibm.com/infocenter/ledoc/v6r2/topic/com.ibm.rcp.tools.doc.appdev/devapps_developingwiththejcldesktopjre.html
for more information on DesktopEE.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message