db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kathey Marsden (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (DERBY-3555) Hang forever while trying to run "ant junitreport"
Date Mon, 17 Nov 2008 18:23:44 GMT

     [ https://issues.apache.org/jira/browse/DERBY-3555?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kathey Marsden resolved DERBY-3555.
-----------------------------------

    Resolution: Duplicate

>From Mike's comments this is a dup of DERBY-3544


> Hang forever while trying to run "ant junitreport"
> --------------------------------------------------
>
>                 Key: DERBY-3555
>                 URL: https://issues.apache.org/jira/browse/DERBY-3555
>             Project: Derby
>          Issue Type: Bug
>          Components: Regression Test Failure
>    Affects Versions: 10.5.0.0
>         Environment: sane classes built off of trunk on a windows XP machine with 4 processors
> i am actually now not sure what jvm was running (likely sun jdk15), am new to running
the ant junitreport target.  In my environment
> the jvm for ant gets hardcoded and I count on the path to get me to the jvm that i am
trying to test.  But I think this
> is not working for running the tests through ant.
>            Reporter: Mike Matrigali
>         Attachments: junit_20080319_1111.zip
>
>
> Running "ant junit report" has consistently hung forever in this configuration (I think
I have tried about 4 times on various latest builds off of the trunk".  The latest try was
against build 638425.  I will attach a zip of the junit report information.  On windows I
could only get the stack trace from the ant control jvm, not sure how to get the actual test
jvm to dump javacore to see what is going on there.  I have been able to consistently run
"ant junitreport" against the trunk and ibm15 jvm, this is the first time on this machine
I have tried running the tests this way against ibm16.  
> I will also try going back to the direct runner separate from ant to see if maybe the
hang is ant related.  In the old harness I have seen timing issues with the control and child
jvm getting out of sync.  

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message