db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mamta Satoor" <msat...@gmail.com>
Subject Re: Help with build.xml so that DataDictionary class will compile with jdk1.5 and higher...
Date Tue, 02 Sep 2008 22:53:03 GMT
No, this is temporary. I plan on extending DataDictionary by
subclassing it which will be loaded only when running with jdk 1.5 and
higher. I am trying to break that task into mini-tasks by first making
changes directly to DataDictionary. This subtask will not be
committed. It is only for my local codeline. Once it works in my local
codeline, I will subclass DataDictionary to move jdk15 specific stuff
in that subclass.

Hope this answers your question, Kathey.

Mamta

On 9/2/08, Kathey Marsden <kmarsdenderby@sbcglobal.net> wrote:
> Mamta Satoor wrote:
> > I have made a very simple change to
> > iapi.sql.dictionary.DataDictionary.java which is to
> import
> > java.util.concurrent.ThreadPoolExecutor;
> >
> >
> >
>
> Will everything still run ok on jdk 1.4.2 if we do this?
>
> Thanks
>
> Kathey
>
>
>

Mime
View raw message