db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bryan Pendleton (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-3762) Convert "org.apache.derbyTesting.functionTests.tests.lang.arithmetic.sql" to junit.
Date Thu, 10 Jul 2008 16:46:32 GMT

    [ https://issues.apache.org/jira/browse/DERBY-3762?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12612564#action_12612564

Bryan Pendleton commented on DERBY-3762:

Thanks for the patch!

I noticed that there seem to be public methods named testXXX, and private
methods named testYYY, and the private methods appear to be 'helper'
functions for the public test case methods.

I think that's a bit confusing; I think it would be a bit clearer to use a different
naming convention for the private test methods to make it more obvious
that they are not test cases themselves, but rather are helper methods
for the other test cases.

Perhaps the private methods could be renamed from 'testYYY' to
'doYYY' or 'performYYY' or some similar naming convention to help
distinguish them.

> Convert "org.apache.derbyTesting.functionTests.tests.lang.arithmetic.sql" to junit. 
> ------------------------------------------------------------------------------------
>                 Key: DERBY-3762
>                 URL: https://issues.apache.org/jira/browse/DERBY-3762
>             Project: Derby
>          Issue Type: Test
>         Environment: windows xp, sp2.
>            Reporter: Junjie Peng
>            Assignee: Junjie Peng
>         Attachments: derby-3762-1-patch.txt, derby-3762-1-stat.txt, derby-3762-2-patch.txt,
>   Original Estimate: 120h
>  Remaining Estimate: 120h
> Convert "org.apache.derbyTesting.functionTests.tests.lang.arithmetic.sql" to junit. It
it a part of 2008 GSOC.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message