db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Pendleton <bpendle...@amberpoint.com>
Subject Re: Unsupported upgrade Exception when running a test
Date Sat, 19 Jul 2008 15:24:10 GMT
> Exception in thread "main" java.sql.SQLException: Failed to start
> database 'wombat', see the next exception for details.

> Caused by: java.sql.SQLException: Unsupported upgrade from '10.4' to
> '10.5 beta'.

> Caused by: ERROR XCW00: Unsupported upgrade from '10.4' to '10.5 beta'.

> Does anyone know what might be causing this and how I can rectify it?

Many of the tests tend to use the database 'wombat' as their test db.
It sounds like you were recently running some tests with Derby 10.4
and then switched to using the trunk code, but the old database
was still present.

The easiest thing to do is just remove the old database: 'rm -r wombat'
or on Windows 'rmdir /s wombat'.

thanks,

bryan

P.S. I am sort of in the habit of always going to a special
directory called 'tests' when I'm running various Derby tests.
Then I periodically do 'cd tests; rm -r *' to start fresh with
a new set of code.


Mime
View raw message