db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dag H. Wanvik (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (DERBY-3763) Rename BaseJDBCTestCase.usingDerbyNet
Date Tue, 08 Jul 2008 12:38:36 GMT

    [ https://issues.apache.org/jira/browse/DERBY-3763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12611555#action_12611555
] 

dagw edited comment on DERBY-3763 at 7/8/08 5:37 AM:
--------------------------------------------------------------

I am OK with the name change, but just a nit: In the test BlobClob4BlobTest
you have for example this line:

        } catch (StringIndexOutOfBoundsException se) {
            assertTrue("FAIL - This exception should only happen with DerbyNet",
                    usingDerbyNet());

If you change the name of the method, the explanatory message should 
probably be changes as well:

             assertTrue("FAIL - This exception should only happen with DB2 client",
                    usingDB2Client());

There are several other instances of this.

A data point, the "Net=db2 client", "Client=Derby client" convention
is still used in the old (non-JUnit tests), but I agree it is better
to remove this source of confusion and be explicit as you propose.



      was (Author: dagw):
    I am OK with the name change, but just a nit: In the test BlobClob4BlobTest
you have for example this line:

        } catch (StringIndexOutOfBoundsException se) {
            assertTrue("FAIL - This exception should only happen with DerbyNet",
                    usingDerbyNet());

If you change the name of the method, the explanatory message should 
probably be changes as well:

             assertTrue("FAIL - This exception should only happen with DB2 client",
+                    usingDB2Client());

There are several other instances of this.

A data point, the "Net=db2 client", "Client=Derby client" convention
is still used in the old (non-JUnit tests), but I agree it is better
to remove this source of confusion and be explicit as you propose.


  
> Rename BaseJDBCTestCase.usingDerbyNet
> -------------------------------------
>
>                 Key: DERBY-3763
>                 URL: https://issues.apache.org/jira/browse/DERBY-3763
>             Project: Derby
>          Issue Type: Improvement
>          Components: Test
>    Affects Versions: 10.5.0.0
>            Reporter: Kristian Waagan
>            Assignee: Kristian Waagan
>            Priority: Trivial
>         Attachments: derby-3763-1a-usingDB2Client.diff, derby-3763-1a-usingDB2Client.stat
>
>
> The names of the methods 'usingDerbyNet' and 'usingDerbyNetClient' in BaseJDBCTestCase
are confusing.
> I propose we change the one used to tell if we are using the DB2 client driver (JCC).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message