db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kim Haase (JIRA)" <j...@apache.org>
Subject [jira] Closed: (DERBY-3756) Tools Guide topic for GET CURSOR command needs fixing
Date Thu, 03 Jul 2008 17:27:45 GMT

     [ https://issues.apache.org/jira/browse/DERBY-3756?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kim Haase closed DERBY-3756.
----------------------------

    Resolution: Invalid

My apologies. There is a separate topic for GET SCROLL INSENSITIVE cursor. Sorry for the noise.


> Tools Guide topic for GET CURSOR command needs fixing
> -----------------------------------------------------
>
>                 Key: DERBY-3756
>                 URL: https://issues.apache.org/jira/browse/DERBY-3756
>             Project: Derby
>          Issue Type: Bug
>          Components: Documentation
>    Affects Versions: 10.4.1.3
>            Reporter: Kim Haase
>            Assignee: Kim Haase
>            Priority: Minor
>
> DERBY-3755 points out that the syntax for GET CURSOR shown in the the ij tool's help
command is incomplete. However, if the syntax shown in ij is correct, the syntax in the Tools
Guide topic for GET CURSOR is also incomplete, because it does not include the optional SCROLL
INSENSITIVE. The complete syntax should be 
> GET [SCROLL INSENSITIVE] [WITH {HOLD|NOHOLD}] CURSOR Identifier AS String
> SCROLL INSENSITIVE is the default, and SCROLL SENSITIVE is not supported, so there is
no need to specify it. However, we should indicate that this syntax is supported.
> Another fix that can now be made is to remove the following note, since Derby now supports
no Java version below 1.4.
> Note: WITH NOHOLD is only available in Java 2 Platform, Standard Edition, v 1.4 (J2SE)
or higher.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message