db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kathey Marsden <kmarsdende...@sbcglobal.net>
Subject Re: Ant 1.6.5 and current trunk
Date Sat, 28 Jun 2008 03:04:44 GMT
Bryan Pendleton wrote:
> I'm having troubles building the current trunk with Ant 1.6.5.
>
> I seem to recall somebody (Knut Anders?) posting something about
> a similar problem recently.
>
> Is there a fix for this? A workaround?
>
> thanks,
>
> bryan
>
> P.S. Here's the error I get:
>
> jsr169stubs:
>     [mkdir] Created dir: 
> /home2/bpendleton/src/derby/work/trunk/classes/stubs
>     [mkdir] Created dir: 
> /home2/bpendleton/src/derby/work/trunk/classes/stubs/jsr169
>     [javac] Compiling 26 source files to 
> /home2/bpendleton/src/derby/work/trunk/classes/stubs/jsr169
>     [javac] Fatal Error: Unable to find package java.lang in classpath 
> or bootclasspath
>
> BUILD FAILED
> /home2/bpendleton/src/derby/work/trunk/build.xml:598: Compile failed; 
> see the compiler error output for details.
>
>
Knut checked in this change which I think was supposed to fix it. 

Author: kahatlen
Date: Fri Jun 27 01:41:48 2008
New Revision: 672190

URL: http://svn.apache.org/viewvc?rev=672190&view=rev
Log:
DERBY-3703: Make it possible to build the JSR169 support with the jdk1.4 libraries

Fixed build break with ant 1.6.5 (not seen with ant 1.7.0):
  * make sure setCompilerProperties is invoked before jsr169stubs
  * remove use of Java 1.5 classes in java.sql.Timestamp






Mime
View raw message