db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tiago Espinha" <ti...@espinhas.net>
Subject Re: [jira] Commented: (DERBY-3574) With client, attempting to get the lob length after commit or connection close if there was a call to length() before commit does not throw an exception
Date Sat, 12 Apr 2008 22:49:53 GMT
On Sat, Apr 12, 2008 at 10:59 PM, Myrna van Lunteren <m.v.lunteren@gmail.com>

> On 4/12/08, Tiago R. Espinha (JIRA) <jira@apache.org> wrote:
> >
> >    [
> https://issues.apache.org/jira/browse/DERBY-3574?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12588315#action_12588315]
> >
> > Tiago R. Espinha commented on DERBY-3574:
> > -----------------------------------------
> >
> > Ok I have a problem.
> >
> > I ran the command that Kathey posted (without the -D switch and with
> -Xmx1024M since it gave out of memory with just 512MiB) and I got a
> stackload of error lines after a few hours of running. Here's what it said
> in the end:
> >
> > Tests run: 8010,  Failures: 1,  Errors: 8
> >
> > Somehow I get the feeling that this is still a memory issue. I'm running
> the tests in a Virtual Machine running Ubuntu 7.10 with just 1GiB of RAM,
> and after a while, java is using all the RAM and has entered the swap file.
> Should I discard the VM and run it all natively on XP where I have 2GiB of
> RAM?
> >
> Actually, considering 8010 fixtures were run, 9 failing fixtures is
> not that bad...
> And yes, you'd get a stack for each of the failures/errors; that is to
> help analyze the problems - obviously, there is something off still.
> I'm not entirely certain what is enough RAM these days, but I can run
> on a windows machine with 1.5 Gi RAM, and I used to be able to run on
> a box that had 1/4 Gi, although it's been a while I tried it (machine
> is slow as well as not much RAM). Ubuntu should be fine too.
> What made you think there was still a memory issue, did any of the
> error messages on the stacks indicate so?
> I'm curious to see an example of the stack traces.
> Myrna

Well, on a second check, it's definitely memory-related. Check this bit out:
E.java.io.IOException: java.io.IOException: Cannot allocate memory
        at java.lang.UNIXProcess.<init>(UNIXProcess.java:143)
        at java.lang.Runtime.execInternal(Native Method)
        at java.lang.Runtime.exec(Runtime.java:566)
        at java.lang.Runtime.exec(Runtime.java:428)
        at java.lang.Thread.run(Thread.java:534)
And it keeps going on and on throwing that one. Towards the end there were
Unexpected SQLException: -1 08004 DERBY SQL error: SQLCODE: -1, SQLSTATE:
08004, SQLERRMC: Connection refused : java.sql.SQLException: Required
property 'slaveHost' has not been set.
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
        at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
        at junit.extensions.TestSetup.run(TestSetup.java:23)

How should I proceed? Do I inflate the swap file?

View raw message