db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dyre Tjeldvoll <Dyre.Tjeldv...@Sun.COM>
Subject Re: Forrest trouble
Date Thu, 17 Apr 2008 20:37:17 GMT
Rick Hillegas wrote:
> Dyre.Tjeldvoll@Sun.COM wrote:
>> Hi,
>>
>> I've started updating the download page in my website sandbox to prepare
>> for the coming release. For now I have created 10.4.x.y.{cgi,html} and
>> updated dowloads.xml to refer to the cgi script, and conf/cli.xconf to
>> refer to the html (as the Wiki says). But when I run 'forrest site' 
>> only the
>> cgi gets copied to build/site.
>>
>> I have not run 'svn add' on the files yet (don't want to do that until
>> I'm sure what the new final version is). Could that be causing the
>> problem?
>>   
> Hi Dyre,
> 
> You may be running into the problem described in item (b) of the section 
> titled "Create a page for the release, build/update site" in the release 
> instructions: 
> http://wiki.apache.org/db-derby/DerbySnapshotOrRelease#head-60891cacca1830fb413f25400647daa1436c21df

> This is a Forrest bug: http://issues.apache.org/jira/browse/FOR-480 The 
> release instructions summarize the problem this way: "the release page 
> will be built into your $FORREST_HOME/main/site directory. You will need 
> to copy it to the build directory."


Thanks Andrew and Rick. I guess that must be it. I did see the Wiki 
mentioning FOR-480, but I assumed that ALL the build products would end 
up in $FORREST_HOME/main/site, not just the new file. So since most 
things ended up in the correct place I thought that there must be some 
other problem...

Dyre

Mime
View raw message