db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Embretsen <John.Embret...@Sun.COM>
Subject Re: running unit tests on IBM Java 6 on Ubuntu 7
Date Wed, 16 Apr 2008 15:11:22 GMT
Rick Hillegas wrote:
> I am trying to run unit tests on the IBM Java 6 platform on Ubuntu 7. I
> notice that this combination is not recorded in our list of "known good"
> platforms: http://wiki.apache.org/db-derby/PlatformTestsDerby However, I
> suspect that that page is not kept up-to-date and someone is probably
> successfully testing on this combination. I am seeing JMX related
> errors. Any advice would be appreciated. Here's what I'm seeing.
> Thanks-Rick

Looks weird... Do you see such exceptions when you simply try to boot the
network server (with a security manager) or the embedded driver in ij or a Java
program as well, or only when running unit tests?

Regarding the JMX-related error it seems like there is an issue when accessing
the platform MBean Server. It complains that it can't find the method
getMBeanInfo, which is part of the javax.management.MBeanServerConnection
interface as well as the javax.management.StandardMBean class.

The other errors (NoClassDefFound, EmbeddedDriver) are equally strange, and I
have no idea what could cause them. I have not tried running on Ubuntu myself,
though. Tried IBM's 1.6 VM on Red Hat 4, and it seemed to work fine.

-- 
John


> There were 3 errors:
> 1)
> noSpecialCollation(org.apache.derbyTesting.functionTests.tests.lang.TableFunctionTest)java.lang.InternalError:
> Failed to get bean info.
>   at gnu.javax.management.Server.checkSecurity(libgcj.so.81)
>   at gnu.javax.management.Server.getAttribute(libgcj.so.81)
>   at javax.management.MBeanServerFactory.createMBeanServer(libgcj.so.81)
>   at javax.management.MBeanServerFactory.createMBeanServer(libgcj.so.81)
>   at
> java.lang.management.ManagementFactory.getPlatformMBeanServer(libgcj.so.8
(...)
> Caused by: java.lang.NoSuchMethodException: getMBeanInfo
>   at java.lang.Class.getMethod(libgcj.so.81)
>   at gnu.javax.management.Server.checkSecurity(libgcj.so.81)
>   ...40 more
> 2) TableFunctionTest:territory=enjava.lang.NoClassDefFoundError:
> org.apache.derby.jdbc.EmbeddedDriver
>   at java.lang.Class.initializeClass(libgcj.so.81)
>   at org.apache.derby.jdbc.EmbeddedDataSource.findDriver(Unknown Source)
(...)





Mime
View raw message