db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myrna van Lunteren (JIRA)" <j...@apache.org>
Subject [jira] Closed: (DERBY-1003) store/bootLock.java fails with J2ME/CDC/FP
Date Sat, 19 Apr 2008 05:52:21 GMT

     [ https://issues.apache.org/jira/browse/DERBY-1003?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Myrna van Lunteren closed DERBY-1003.
-------------------------------------

    Resolution: Cannot Reproduce

The recent report is not a re-occurrence; it is undoubtedly a problem with the setup. That
error is always issued by this jvm when something in the setup is amiss; the original problem
did not report this error and was thus something else.

I ran the test on my machine and it passes fine; the setup issues should be dealt with separately;
I suggest checking path settings including bootclasspath and other values passed in to the
jvm.

Setting back to original closing value.

> store/bootLock.java fails with J2ME/CDC/FP
> ------------------------------------------
>
>                 Key: DERBY-1003
>                 URL: https://issues.apache.org/jira/browse/DERBY-1003
>             Project: Derby
>          Issue Type: Test
>          Components: Regression Test Failure
>    Affects Versions: 10.2.1.6
>         Environment: IBM WCTME 5.7 j9_foundation
>            Reporter: Deepa Remesh
>
> store/bootLock.java failed with j9_foundation VM in the weekend run. I ran this test
few times on my machine and the test does not fail. Also, there was no exception in the weekend
run failure. It seems like the second jvm which is started to boot Derby did not start in
time.
> What test does: 
> The test starts a second jvm (by calling store/bootLock1.java) which boots Derby. The
test sleeps for some time waiting for the second jvm to start and boot Derby. Then it tries
to boot Derby again and should get an expected exception for double-booting. From the failure,
it seems like this second jvm did not start at all. I am guessing this could be a timing issue.
I'll check if the test fails this weekend too.
> If anyone else sees this test fail with j9_foundation VM and has more information, please
update this JIRA.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message