db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myrna van Lunteren" <m.v.lunte...@gmail.com>
Subject Re: Eclipse plugin
Date Wed, 19 Mar 2008 13:27:38 GMT
On 3/18/08, Manjula Kutty <manjula.kutty@gmail.com> wrote:
> Hi,
>
> I have seen that some changes had gone in to the eclipse plugin since
> 10.3.1.4 release. But the version is still 1.1.1. I strongly feel that we
> should make the version to 1.1.2. what do you think? Also if I make the
> changes to the plugin.xml do I have check that in and build the core plugin
> again?
>
> -Manjula
>
You're right Manjula, I also think we should get a new version number
before releasing the updated plugin. The changes for DERBY-1931 -
revision http://svn.apache.org/viewvc?view=rev&revision=581971
were extensive enough...
Probably also the doc plugin merits a second look, to see if maybe
this change for DERBY-1931 merits some documentation.

I don't think the core plugin needs to be regenerated for a chance to
the plugins - looking at it (after unzipping, and looking at the
plugin.xml with a text editor) it only contains derby.jar,
derbyclient.jar, derbytools.jar, derbynet.jar, derbyrun.jar; a
LICENSE, a NOTICE file, and the plugin.xml for the core plugin which
only shows the jars included and the derby version (10.4.1.0).

I do wonder, whether the core plugin.xml has a problem as it doesn't
mention derbyrun.jar, although it is included...Maybe that was an
oversight from when derbyrun.jar was added to the plugin? If we fix
this, we will have to regenerate the core plugin. I think the release
candidate will be soon enough for that.

The doc and ui plugins of course should get generated with the correct
versions in their plugin.xml files.

hth
Myrna

Mime
View raw message