db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kathey Marsden <kmars...@apache.org>
Subject Trouble getting jvm options to work with suites
Date Wed, 13 Feb 2008 00:47:15 GMT
I am trying to run the whole suite with jit forced on with IBM JDK 1.6.  
To do this I use the
-Xjit:count=0 option, but I am having trouble getting it to work when I 
run a suite.
If I run a single test jdbcapi.DatabaseMetaDataTest with the 
-Xjit:count=0, all works as expected and I see the failures for 
DERBY-3400, but if I run a suite, such as jdbcapi._Suite, I don't see 
any failures so I don't think the options are taking effect. 
Here are the two command lines:

Works as expected: 4 tests fail:
java -Xjit:count=0 -Dderby.tests.trace=true junit.textui.TestRunner 

All tests pass:
java -Xjit:count=0 -Dderby.tests.trace=true junit.textui.TestRunner 

I don't think the tests fork a process or anything so I don't understand 
how I could be losing the -Xjit:count=0 option. Does anyone have any 
idea what might be going on?


View raw message