db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Serge Tsv (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DERBY-3437) Give all replication threads meaningfull names
Date Sat, 23 Feb 2008 09:53:19 GMT

    [ https://issues.apache.org/jira/browse/DERBY-3437?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12571714#action_12571714

Serge Tsv commented on DERBY-3437:

If a database name should be a part of a replication threads names, then I think the following
thread naming scheme could be used:
    derby.(slave or master)_dbname.threadtype,

e.g. derby.slave_dbname.boot, derby.master_dbname.logger etc.

I assume it's not necessary to include a component name (e.g. "repl") as a part of a name
thread, as "slave" and "master" implicitly refer to replication.

I will try to reproduce the replication process, so I could see the thread in the jconsole.
Then I'll make the changes, test them and will submit the patch.


> Give all replication threads meaningfull names
> ----------------------------------------------
>                 Key: DERBY-3437
>                 URL: https://issues.apache.org/jira/browse/DERBY-3437
>             Project: Derby
>          Issue Type: Improvement
>          Components: Newcomer, Replication
>    Affects Versions:
>            Reporter: Jørgen Løland
>            Assignee: Serge Tsv
>            Priority: Minor
> Some threads are created for replication purposes:
> * The log shipper thread on the master (o.a.d.i.services.master.MasterController)
> * The database boot thread on the slave (o.a.d.i.db.SlaveDatabase)
> * The log receiver thread on the slave (o.a.d.i.services.slave.SlaveController)
> These threads should be given names to simplify debugging.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message