db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Knut Anders Hatlen (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DERBY-3117) Adjust master build script to require the Java 5 compiler to build Derby
Date Fri, 08 Feb 2008 10:44:08 GMT

     [ https://issues.apache.org/jira/browse/DERBY-3117?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Knut Anders Hatlen updated DERBY-3117:
--------------------------------------

    Attachment: d3117-concurrent.diff

Attaching d3117-concurrent.diff. This patch compiles the code that depends on the java.util.concurrent
package with JDK 1.5 instead of JDK 1.6. Also uncommented the entries for these classes in
modules.properties, and removed the corresponding rewrite rule, since it's no longer an optional
part of the build after this change.

I have verified that the classes that depend on JDK 1.5 are built when jdk16 is not defined
in ant.properties, and that the different Java versions (1.4, 1.5 and 1.6) pick up the correct
classes at run time. suites.All ran cleanly.

Committed revision 619828.

> Adjust master build script to require the Java 5 compiler to build Derby
> ------------------------------------------------------------------------
>
>                 Key: DERBY-3117
>                 URL: https://issues.apache.org/jira/browse/DERBY-3117
>             Project: Derby
>          Issue Type: Improvement
>          Components: Build tools
>    Affects Versions: 10.4.0.0
>            Reporter: Rick Hillegas
>            Assignee: Rick Hillegas
>         Attachments: BuildDefaults.txt, d3117-concurrent.diff, d3117-solaris.diff, derby-3117-01-enforceJava5-aa.diff,
derby-3117-01-enforceJava5-ab.diff, derby-3117-01-enforceJava5-ac.diff, derby-3117-02-website-aa.diff,
derby-3117-03-junit-aa.diff, derby-3117-04-propertySetter-aa.diff, derby-3117-04-propertySetter-ab.diff,
derby-3117-04-propertySetter-ac.diff, derby-3117-04-propertySetter-ad.diff, derby-3117-04-propertySetter-ae.diff,
derby-3117-04-propertySetter-af.diff, derby-3117-04-propertySetter-ag.diff, derby-3117-04-propertySetter-ah.diff,
derby-3117-05-setterCleanup-aa.diff, derby-3117-06-setterDefault-aa.diff, derby-3117-07-buildInstructions-aa.diff,
derby-3117-08a-j15libBuildingInstr.diff, derby-3117-09-leopard-PropertySetter.diff, derby_source.html
>
>
> Require the Java 5 compiler in order to build Derby as approved by the community recently:
http://www.nabble.com/-VOTE--Require-Java-5-%28or-later%29-compiler-to-build-Derby-tf4522491.html#a13030783

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message