db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dibyendu Majumdar (JIRA)" <j...@apache.org>
Subject [jira] Updated: (DERBY-3461) EmbedSQLWarning should be renamed SQLWarningFactory and return java.sql.SQLWarning objects and not a Derby specific implementation.
Date Wed, 27 Feb 2008 01:36:51 GMT

     [ https://issues.apache.org/jira/browse/DERBY-3461?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dibyendu Majumdar updated DERBY-3461:
-------------------------------------

    Attachment:     (was: DERBY-3461_patch_1_r631372.txt)

> EmbedSQLWarning should be renamed SQLWarningFactory and return java.sql.SQLWarning objects
and not a Derby specific implementation.
> -----------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-3461
>                 URL: https://issues.apache.org/jira/browse/DERBY-3461
>             Project: Derby
>          Issue Type: Improvement
>          Components: JDBC, Services
>            Reporter: Daniel John Debrunner
>            Assignee: Dibyendu Majumdar
>            Priority: Minor
>
> One side effect is that the toString() of such a warning would change format from starting
with "SQLWarning: " to "java.sql.SQLWarning: ", which should match any warnings created on
the network client side.
> See comments in DERBY-3453 as well for possible correct package of SQLWarningFactory.
> Note: generateCsSQLWarning() can be removed as it doesn't seem to be used.
> Note: Also SQLWarningFactory would not extend java.sql.SQLWarning.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message