db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kathey Marsden <kmarsdende...@sbcglobal.net>
Subject Re: Compatibility issue for 10.4
Date Mon, 14 Jan 2008 18:44:09 GMT
Rick Hillegas wrote:
> The system privileges work (DERBY-2109) will introduce a compatibility 
> issue for 10.4. 
Thank you Rick for bringing up this issue.

>
> 1) If the customer has written their own security policy file (the 
> usual and recommended situation), then the customer will need to add 
> some extra permissions to that policy file.
>
The need to change the policy file at the end user site is one of the 
most disruptive upgrade requirements and I feel will discourage or cause 
problems with upgrade, so I think should be done incrementally. Perhaps 
we could have a strong warning for 10.4 and then make the policy file 
change a requirement for 10.5.  Of course one could argue that delaying 
the pain would just  mean more users are likely to  be hit, so it will 
be interesting to see what the feedback from others is.

Kathey



Mime
View raw message