db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dag.Wan...@Sun.COM (Dag H. Wanvik)
Subject Re: Javadoc build problems with JDK 1.5 code?
Date Wed, 12 Dec 2007 13:09:29 GMT
Martin Zaun <Martin.Zaun@Sun.COM> writes:

> Hi,
> running 'ant javadoc' in the trunk aborts with jdk-1.5-related errors.
> I was wondering if they've been worked on already, since there was an
> old email thread and we decided to require JDK 1.5.
> Also, I'd like to use the {@code ...} tag for easy quoting of verbatim
> text in javadocs, which requires JDK 1.5.
> To fix the javadoc errors, I simply had to increase the "vmlevel" value
> to "1.5" under:  <target name="testing-javadoc-14" unless="jdk16">...
> Comments?

I guess that's tantamount to having source which is at level 1.4 in
the code, but the corresponding javadocs are at level 1.5. Not sure it
is a problem, though. It does add some potential for confusion as to
the source level to the build.xml, so the change should be commented
well. It seems good to be able to use to @code tag:


I did the javadoc build on my machine with this change and it
seemed to work.

But I am not familiar enough with the build system to vouch for its


View raw message