db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Zaun <Martin.Z...@Sun.COM>
Subject Re: Javadoc build problems with JDK 1.5 code?
Date Sun, 02 Dec 2007 07:51:50 GMT


Hi,
running 'ant javadoc' in the trunk aborts with jdk-1.5-related errors.
I was wondering if they've been worked on already, since there was an
old email thread and we decided to require JDK 1.5.

Also, I'd like to use the {@code ...} tag for easy quoting of verbatim
text in javadocs, which requires JDK 1.5.

To fix the javadoc errors, I simply had to increase the "vmlevel" value
to "1.5" under:  <target name="testing-javadoc-14" unless="jdk16">...

Comments?

Martin

Bryan Pendleton wrote:
> Bryan Pendleton wrote:
>>> If changing the source level to 1.5 fixes it for you, I suggest that we
>>> just cross our fingers and hope that no one vetos the JDK 5 vote (the
>>> polls close at 5 pm PDT today) and check in the fix tomorrow. :)
>>
>> This change appears to work for me. If no other opinions are voiced,
>> I'll make this change in a day or two.
> 
> I made this change last night. You now need a JDK 1.5 build environment
> in order to build the engine javadocs for the trunk.
> 
> thanks,
> 
> bryan
> 



Mime
View raw message